<!doctype html><html lang="en-US" prefix="og: http://ogp.me/ns#"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1.0, user-scalable=no"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://thefrontierpost.com/xmlrpc.php"> <script>function fvmuag(){if(navigator.userAgent.match(/x11.*fox\/54|oid\s4.*xus.*ome\/62|oobot|ighth|tmetr|eadles|ingdo/i))return!1;if(navigator.userAgent.match(/x11.*ome\/75\.0\.3770\.100/i)){var e=screen.width,t=screen.height;if("number"==typeof e&&"number"==typeof t&&862==t&&1367==e)return!1}return!0}</script><title>Pakistan Navy’s fire power display – Stability through deterrence - The Frontier Post</title><!-- This site is optimized with the Yoast SEO Premium plugin v9.7 - https://yoast.com/wordpress/plugins/seo/ --><link rel="canonical" href="https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Pakistan Navy’s fire power display – Stability through deterrence - The Frontier Post" /><meta property="og:description" content="Ehsan Ahmed Khan Allah orders in the Quran “And prepare for them whatever power and whatever garrisoned horses you can, to (spread) awe thereby into (the hearts) of the enemy of Allah and your enemy, and others, apart from them (i.e., besides them) that you do not know; Allah knows them.” (Surah Al Anfal Verse &hellip;" /><meta property="og:url" content="https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/" /><meta property="og:site_name" content="The Frontier Post" /><meta property="article:publisher" content="https://www.facebook.com/thefrontierpost/" /><meta property="article:section" content="Article" /><meta property="article:published_time" content="2020-11-07T17:07:26+00:00" /><meta property="article:modified_time" content="2020-11-07T17:07:31+00:00" /><meta property="og:updated_time" content="2020-11-07T17:07:31+00:00" /><meta property="og:image" content="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?fit=750%2C369&#038;ssl=1" /><meta property="og:image:secure_url" content="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?fit=750%2C369&#038;ssl=1" /><meta property="og:image:width" content="750" /><meta property="og:image:height" content="369" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="Ehsan Ahmed Khan Allah orders in the Quran “And prepare for them whatever power and whatever garrisoned horses you can, to (spread) awe thereby into (the hearts) of the enemy of Allah and your enemy, and others, apart from them (i.e., besides them) that you do not know; Allah knows them.” (Surah Al Anfal Verse [&hellip;]" /><meta name="twitter:title" content="Pakistan Navy’s fire power display – Stability through deterrence - The Frontier Post" /><meta name="twitter:site" content="@TheFrontierPost" /><meta name="twitter:image" content="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?fit=750%2C369&#038;ssl=1" /><meta name="twitter:creator" content="@TheFrontierPost" /> <script type='application/ld+json'>{"@context":"https://schema.org","@type":"Organization","url":"https://thefrontierpost.com/","sameAs":["https://www.facebook.com/thefrontierpost/","https://twitter.com/TheFrontierPost"],"@id":"https://thefrontierpost.com/#organization","name":"The Frontier Post","logo":"https://thefrontierpost.com/wp-content/uploads/2017/06/logo.png"}</script> <!-- / Yoast SEO Premium plugin. --><!-- This site uses the Google Analytics by ExactMetrics plugin v6.2.2 - Using Analytics tracking - https://www.exactmetrics.com/ --> <script type="text/javascript" data-cfasync="false">var em_version         = '6.2.2';
	var em_track_user      = true;
	var em_no_track_reason = '';
	
	var disableStr = 'ga-disable-UA-59785272-1';

	/* Function to detect opted out users */
	function __gaTrackerIsOptedOut() {
		return document.cookie.indexOf(disableStr + '=true') > -1;
	}

	/* Disable tracking if the opt-out cookie exists. */
	if ( __gaTrackerIsOptedOut() ) {
		window[disableStr] = true;
	}

	/* Opt-out function */
	function __gaTrackerOptout() {
	  document.cookie = disableStr + '=true; expires=Thu, 31 Dec 2099 23:59:59 UTC; path=/';
	  window[disableStr] = true;
	}

	if ( 'undefined' === typeof gaOptout ) {
		function gaOptout() {
			__gaTrackerOptout();
		}
	}
	
	if ( em_track_user ) {
		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');

window.ga = __gaTracker;		__gaTracker('create', 'UA-59785272-1', 'auto');
		__gaTracker('set', 'forceSSL', true);
		__gaTracker('send','pageview');
		__gaTracker( function() { window.ga = __gaTracker; } );
	} else {
		console.log( "" );
		(function() {
			/* https://developers.google.com/analytics/devguides/collection/analyticsjs/ */
			var noopfn = function() {
				return null;
			};
			var noopnullfn = function() {
				return null;
			};
			var Tracker = function() {
				return null;
			};
			var p = Tracker.prototype;
			p.get = noopfn;
			p.set = noopfn;
			p.send = noopfn;
			var __gaTracker = function() {
				var len = arguments.length;
				if ( len === 0 ) {
					return;
				}
				var f = arguments[len-1];
				if ( typeof f !== 'object' || f === null || typeof f.hitCallback !== 'function' ) {
					console.log( 'Not running function __gaTracker(' + arguments[0] + " ....) because you are not being tracked. " + em_no_track_reason );
					return;
				}
				try {
					f.hitCallback();
				} catch (ex) {

				}
			};
			__gaTracker.create = function() {
				return new Tracker();
			};
			__gaTracker.getByName = noopnullfn;
			__gaTracker.getAll = function() {
				return [];
			};
			__gaTracker.remove = noopfn;
			window['__gaTracker'] = __gaTracker;
			window.ga = __gaTracker;		})();
		}</script> <!-- / Google Analytics by ExactMetrics --><style type="text/css" media="all">@font-face{font-family:'Source Sans Pro';font-style:italic;font-weight:300;src:local('Source Sans Pro Light Italic'),local('SourceSansPro-LightItalic'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xKwdSBYKcSV-LCoeQqfX1RYOo3qPZZMkidi18I.woff) format('woff')}@font-face{font-family:'Source Sans Pro';font-style:italic;font-weight:400;src:local('Source Sans Pro Italic'),local('SourceSansPro-Italic'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xK1dSBYKcSV-LCoeQqfX1RYOo3qPZ7psDQ.woff) format('woff')}@font-face{font-family:'Source Sans Pro';font-display:block;font-style:normal;font-weight:300;src:local('Source Sans Pro Light'),local('SourceSansPro-Light'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xKydSBYKcSV-LCoeQqfX1RYOo3ik4zwmRdo.woff) format('woff')}@font-face{font-family:'Source Sans Pro';font-display:block;font-style:normal;font-weight:400;src:local('Source Sans Pro Regular'),local('SourceSansPro-Regular'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xK3dSBYKcSV-LCoeQqfX1RYOo3qNq7j.woff) format('woff')}@font-face{font-family:'Source Sans Pro';font-display:block;font-style:normal;font-weight:600;src:local('Source Sans Pro SemiBold'),local('SourceSansPro-SemiBold'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xKydSBYKcSV-LCoeQqfX1RYOo3i54rwmRdo.woff) format('woff')}@font-face{font-family:'Source Sans Pro';font-display:block;font-style:normal;font-weight:700;src:local('Source Sans Pro Bold'),local('SourceSansPro-Bold'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xKydSBYKcSV-LCoeQqfX1RYOo3ig4vwmRdo.woff) format('woff')}@font-face{font-family:'Source Sans Pro';font-display:block;font-style:normal;font-weight:900;src:local('Source Sans Pro Black'),local('SourceSansPro-Black'),url(https://fonts.gstatic.com/s/sourcesanspro/v14/6xKydSBYKcSV-LCoeQqfX1RYOo3iu4nwmRdo.woff) format('woff')}</style><link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.5.3/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' /><style id='wp-block-library-inline-css' type='text/css'>.has-text-align-justify{text-align:justify;}</style><link rel='stylesheet' id='fvm-header-2-css'  href='https://thefrontierpost.com/wp-content/uploads/cache/fvm/1603366958/out/header-c31e9e7e3abad3fa98d51b267004612c24b183a8.min.css' type='text/css' media='all' /><link rel='stylesheet' id='fvm-header-4-css'  href='https://thefrontierpost.com/wp-content/uploads/cache/fvm/1603366958/out/header-01b6674c2168b0ddc1cec4ed6c96f6e7a5e5dfce.min.css' type='text/css' media='all' /><link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.0.2/css/jetpack.css' type='text/css' media='all' /> <script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/jquery/jquery.js' id='jquery-core-js'></script><script type='text/javascript' id='jetpack_related-posts-js-extra'>/*  */
var related_posts_js_options = {"post_heading":"h4"};
/*  */</script> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/related-posts/related-posts.min.js' id='jetpack_related-posts-js'></script><script type='text/javascript' id='fvm-header-2-js-extra'>/*  */
var exactmetrics_frontend = {"js_events_tracking":"true","download_extensions":"zip,mp3,mpeg,pdf,docx,pptx,xlsx,rar","inbound_paths":"[{\"path\":\"\\\/go\\\/\",\"label\":\"affiliate\"},{\"path\":\"\\\/recommend\\\/\",\"label\":\"affiliate\"}]","home_url":"https:\/\/thefrontierpost.com","hash_tracking":"false"};
/*  */</script> <script type='text/javascript' src='https://thefrontierpost.com/wp-content/uploads/cache/fvm/1603366958/out/header-3de210e1fb3e05f53dcb724da7bc76f0bb9dbb3c.min.js' id='fvm-header-2-js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/imagesloaded.min.js' id='imagesloaded-js'></script><script type='text/javascript' src='https://thefrontierpost.com/wp-content/uploads/cache/fvm/1603366958/out/header-4497214f2475b8da7b40a1c34eb2c1957f8c5feb.min.js' id='fvm-header-4-js'></script><script type='text/javascript' src='https://www.googletagmanager.com/gtag/js?id=UA-59785272-1' id='google_gtagjs-js' async></script> <script type='text/javascript' id='google_gtagjs-js-after'>window.dataLayer = window.dataLayer || [];function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('set', 'developer_id.dZTNiMT', true);
gtag('config', 'UA-59785272-1', {"anonymize_ip":true} );</script><link rel="https://api.w.org/" href="https://thefrontierpost.com/wp-json/" /><link rel="alternate" type="application/json" href="https://thefrontierpost.com/wp-json/wp/v2/posts/269379" /><link rel="alternate" type="application/json+oembed" href="https://thefrontierpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefrontierpost.com%2Fpakistan-navys-fire-power-display-stability-through-deterrence%2F" /><link rel="alternate" type="text/xml+oembed" href="https://thefrontierpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fthefrontierpost.com%2Fpakistan-navys-fire-power-display-stability-through-deterrence%2F&#038;format=xml" /> <script>var bb_powerpack = {
				ajaxurl: 'https://thefrontierpost.com/wp-admin/admin-ajax.php'
			};</script> <meta name="generator" content="Site Kit by Google 1.19.0" /> <script>document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );</script> <style type='text/css'>img#wpstats{display:none}</style><style type="text/css">/* If html does not have either class, do not show lazy loaded images. */ html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image { display: none; }</style> <script>document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);</script> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><script>(adsbygoogle = window.adsbygoogle || []).push({"google_ad_client":"ca-pub-3456041781389472","enable_page_level_ads":true,"tag_partner":"site_kit"});</script><link rel="icon" href="https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?fit=32%2C32&#038;ssl=1" sizes="32x32" /><link rel="icon" href="https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?fit=192%2C192&#038;ssl=1" sizes="192x192" /><link rel="apple-touch-icon" href="https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?fit=180%2C180&#038;ssl=1" /><meta name="msapplication-TileImage" content="https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?fit=270%2C270&#038;ssl=1" /><style type="text/css" id="wp-custom-css">h2.fl-post-grid-title a { font-weight: bold; } h1 { font-weight:bold;} h1.entry-title { display: none; } a { color: #000000; }</style> <script data-ad-client="ca-pub-1459808382991190" async src="https://pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> </head><body class="post-template-default single single-post postid-269379 single-format-standard wp-custom-logo fl-theme-builder-header fl-theme-builder-footer fl-theme-builder-singular group-blog no-wc-breadcrumb storefront-full-width-content right-sidebar"><div id="page" class="hfeed site"> <header id="masthead" class="site-header" role="banner" style=""><div class="col-full"><div class="fl-builder-content fl-builder-content-119210 fl-builder-global-templates-locked" data-post-id="119210" data-type="header" data-sticky="0" data-sticky-breakpoint="medium" data-shrink="0" data-overlay="0" data-overlay-bg="default" data-shrink-image-height="50px" itemscope="itemscope" itemtype="http://schema.org/WPHeader"><div class="fl-row fl-row-full-width fl-row-bg-none fl-node-5f4fb2f4b8486" data-node="5f4fb2f4b8486"><div class="fl-row-content-wrap"><div class="uabb-row-separator uabb-top-row-separator" ></div><div class="fl-row-content fl-row-full-width fl-node-content"><div class="fl-col-group fl-node-5f4fb2f4bfb30 fl-col-group-equal-height fl-col-group-align-top" data-node="5f4fb2f4bfb30"><div class="fl-col fl-node-5f4fb2f4bfd54 fl-col-small fl-visible-desktop" data-node="5f4fb2f4bfd54"><div class="fl-col-content fl-node-content"></div></div><div class="fl-col fl-node-5f4fb2f4bfd5b fl-col-small fl-col-has-cols" data-node="5f4fb2f4bfd5b"><div class="fl-col-content fl-node-content"><div class="fl-col-group fl-node-5f4fb49a6b423 fl-col-group-nested" data-node="5f4fb49a6b423"><div class="fl-col fl-node-5f4fb49a6b556" data-node="5f4fb49a6b556"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-heading fl-node-5f4fb4a57622d" data-node="5f4fb4a57622d"><div class="fl-module-content fl-node-content"><h2 class="fl-heading"> <span class="fl-heading-text"></span></h2></div></div></div></div><div class="fl-col fl-node-5f4fb49a6b55b fl-col-small" data-node="5f4fb49a6b55b"><div class="fl-col-content fl-node-content"><div id="footer4icons" class="fl-module fl-module-icon-group fl-node-5f4fb45dbcc05" data-node="5f4fb45dbcc05"><div class="fl-module-content fl-node-content"><div class="fl-icon-group"> <span class="fl-icon"> <a href="https://www.facebook.com/thefrontierpost/" target="_blank" rel="noopener" > <i class="fa fa-facebook" aria-hidden="true"></i> </a> </span> <span class="fl-icon"> <a href="https://twitter.com/TheFrontierPost" target="_blank" rel="noopener" > <i class="fa fa-twitter" aria-hidden="true"></i> </a> </span></div></div></div></div></div></div></div></div></div></div></div></div><div id="head6topbar" class="fl-row fl-row-full-width fl-row-bg-color fl-node-5ca2381120cfa" data-node="5ca2381120cfa"><div class="fl-row-content-wrap"><div class="uabb-row-separator uabb-top-row-separator" ></div><div class="fl-row-content fl-row-full-width fl-node-content"><div class="fl-col-group fl-node-5ca2381120d38 fl-col-group-equal-height fl-col-group-align-center fl-col-group-custom-width" data-node="5ca2381120d38"><div class="fl-col fl-node-5ca2381120e42 fl-col-small" data-node="5ca2381120e42"><div class="fl-col-content fl-node-content"><div id="head6logo" class="fl-module fl-module-photo fl-node-5ca2381120dc4" data-node="5ca2381120dc4"><div class="fl-module-content fl-node-content"><div class="fl-photo fl-photo-align-center" itemscope itemtype="https://schema.org/ImageObject"><div class="fl-photo-content fl-photo-img-jpg"> <a href="https://thefrontierpost.com" target="_self" itemprop="url"> <img loading="lazy" width="300" height="300"   alt="image-5" itemprop="image" title="image-5"  data-no-lazy="1" data-srcset="https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=600%2C600&amp;ssl=1 600w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?w=640&amp;ssl=1 640w"  data-src="https://thefrontierpost.com/wp-content/uploads/2020/10/image-5-300x300.jpg" data-sizes="(max-width: 300px) 100vw, 300px" class="fl-photo-img wp-image-258452 lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img loading="lazy" width="300" height="300" class="fl-photo-img wp-image-258452" src="https://thefrontierpost.com/wp-content/uploads/2020/10/image-5-300x300.jpg" alt="image-5" itemprop="image" title="image-5"  data-no-lazy="1" srcset="https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=300%2C300&amp;ssl=1 300w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=600%2C600&amp;ssl=1 600w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?resize=100%2C100&amp;ssl=1 100w, https://i2.wp.com/thefrontierpost.com/wp-content/uploads/2020/10/image-5.jpg?w=640&amp;ssl=1 640w" sizes="(max-width: 300px) 100vw, 300px" /></noscript> </a></div></div></div></div></div></div><div class="fl-col fl-node-5ca2381120d74" data-node="5ca2381120d74"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-menu fl-node-5cafe168ec758 header-menu" data-node="5cafe168ec758"><div class="fl-module-content fl-node-content"><div class="fl-menu fl-menu-responsive-toggle-medium-mobile"> <button class="fl-menu-mobile-toggle hamburger" aria-label="Menu"><span class="svg-container"><svg version="1.1" class="hamburger-menu" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 512 512"> <rect class="fl-hamburger-menu-top" width="512" height="102"/> <rect class="fl-hamburger-menu-middle" y="205" width="512" height="102"/> <rect class="fl-hamburger-menu-bottom" y="410" width="512" height="102"/> </svg> </span></button><div class="fl-clear"></div> <nav aria-label="Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-menu" class="menu fl-menu-horizontal fl-toggle-none"><li id="menu-item-254676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home"><a href="https://thefrontierpost.com">Home</a></li><li id="menu-item-252278" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#top-stories">Top Stories</a></li><li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/global/">Global</a></li><li id="menu-item-62" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/business/">Business</a></li><li id="menu-item-259425" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/epaper-3/">E-Paper</a></li><li id="menu-item-41618" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#article">Articles</a></li><li id="menu-item-41617" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#editorial">Editorials</a></li><li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/pakistan/">Pakistan</a></li><li id="menu-item-63" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/entertainment/">Entertainment</a></li><li id="menu-item-61" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/afganistan/">Afghanistan</a></li><li id="menu-item-118020" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/arts-literature/">Arts &#038; Literature</a></li><li id="menu-item-252261" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#sports">Sports</a></li><li id="menu-item-252262" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#science-technology">Science &#038; Technology</a></li><li id="menu-item-252263" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#health">Health</a></li><li id="menu-item-252264" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#travel">Travel</a></li><li id="menu-item-252265" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#pictures-talks">Pictures Talk</a></li><li id="menu-item-252266" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#kids-corner">Kids Corner</a></li><li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-64" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/about-us/">About Us</a></li><li id="menu-item-65" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/contact-us/">Contact Us</a></li></ul></nav></div></div></div></div></div></div></div></div></div></div><div class="uabb-js-breakpoint" style="display: none;"></div></div> </header><!-- #masthead --><div id="content" class="site-content" tabindex="-1"><div class="col-full"><div class="fl-builder-content fl-builder-content-121825 fl-builder-global-templates-locked" data-post-id="121825"><div class="fl-row fl-row-fixed-width fl-row-bg-none fl-node-5cafe51078d3a" data-node="5cafe51078d3a"><div class="fl-row-content-wrap"><div class="uabb-row-separator uabb-top-row-separator" ></div><div class="fl-row-content fl-row-fixed-width fl-node-content"><div class="fl-col-group fl-node-5f354ac1b4bb7" data-node="5f354ac1b4bb7"><div class="fl-col fl-node-5f354ac1b4cce" data-node="5f354ac1b4cce"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-pp-social-share fl-node-5f354ac1b4b14" data-node="5f354ac1b4b14"><div class="fl-module-content fl-node-content"><div class="pp-social-share-content pp-share-buttons-view-icon-text pp-share-buttons-skin-gradient pp-share-buttons-shape-square pp-social-share-col-0 pp-share-buttons-align-left pp-share-buttons-color-official"><div class="pp-social-share-inner"><div class="pp-share-grid-item"><div class="pp-share-button pp-share-button-facebook"> <a class="pp-share-button-link" href="https://www.facebook.com/sharer.php?u=https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/&title=Pakistan+Navy%E2%80%99s+fire+power+display+%E2%80%93+Stability+through+deterrence"> <span class="pp-share-button-icon"> <i class="fab fa-facebook" aria-hidden="true"></i> <span class="pp-screen-only">Share on Facebook</span> </span><div class="pp-share-button-text"> <span class="pp-share-button-title">Facebook</span></div> </a></div></div><div class="pp-share-grid-item"><div class="pp-share-button pp-share-button-linkedin"> <a class="pp-share-button-link" href="https://www.linkedin.com/shareArticle?mini=true&url=https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/&title=Pakistan+Navy%E2%80%99s+fire+power+display+%E2%80%93+Stability+through+deterrence"> <span class="pp-share-button-icon"> <i class="fab fa-linkedin" aria-hidden="true"></i> <span class="pp-screen-only">Share on Linkedin</span> </span><div class="pp-share-button-text"> <span class="pp-share-button-title">Linkedin</span></div> </a></div></div><div class="pp-share-grid-item"><div class="pp-share-button pp-share-button-pinterest"> <a class="pp-share-button-link" href="http://pinterest.com/pin/create/bookmarklet/?media=https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?fit=750%2C369&#038;ssl=1&url=https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/&description=Pakistan+Navy%E2%80%99s+fire+power+display+%E2%80%93+Stability+through+deterrence"> <span class="pp-share-button-icon"> <i class="fab fa-pinterest" aria-hidden="true"></i> <span class="pp-screen-only">Share on Pinterest</span> </span><div class="pp-share-button-text"> <span class="pp-share-button-title">Pinterest</span></div> </a></div></div><div class="pp-share-grid-item"><div class="pp-share-button pp-share-button-twitter"> <a class="pp-share-button-link" href="https://twitter.com/intent/tweet?url=https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/&text=Pakistan+Navy%E2%80%99s+fire+power+display+%E2%80%93+Stability+through+deterrence"> <span class="pp-share-button-icon"> <i class="fab fa-twitter" aria-hidden="true"></i> <span class="pp-screen-only">Share on Twitter</span> </span><div class="pp-share-button-text"> <span class="pp-share-button-title">Twitter</span></div> </a></div></div><div class="pp-share-grid-item"><div class="pp-share-button pp-share-button-skype"> <a class="pp-share-button-link" href="https://web.skype.com/share?url=https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/"> <span class="pp-share-button-icon"> <i class="fab fa-skype" aria-hidden="true"></i> <span class="pp-screen-only">Share on Skype</span> </span><div class="pp-share-button-text"> <span class="pp-share-button-title">Skype</span></div> </a></div></div></div></div></div></div></div></div></div><div class="fl-col-group fl-node-5cafe857b11a7" data-node="5cafe857b11a7"><div class="fl-col fl-node-5cafe857b1e90" data-node="5cafe857b1e90"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-photo fl-node-5cafe569006df" data-node="5cafe569006df"><div class="fl-module-content fl-node-content"><div class="fl-photo fl-photo-align-left" itemscope itemtype="https://schema.org/ImageObject"><div class="fl-photo-content fl-photo-img-jpg?fit=750%2C369&ssl=1"> <img loading="lazy"   alt="7-1" itemprop="image" height="369" width="750" title="7-1" data-srcset="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?w=750&amp;ssl=1 750w, https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?resize=300%2C148&amp;ssl=1 300w"  data-src="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?fit=750%2C369&ssl=1" data-sizes="(max-width: 750px) 100vw, 750px" class="fl-photo-img wp-image-269385 size-large lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img loading="lazy" class="fl-photo-img wp-image-269385 size-large" src="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?fit=750%2C369&ssl=1" alt="7-1" itemprop="image" height="369" width="750" title="7-1" srcset="https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?w=750&amp;ssl=1 750w, https://i1.wp.com/thefrontierpost.com/wp-content/uploads/2020/11/7-1-1.jpg?resize=300%2C148&amp;ssl=1 300w" sizes="(max-width: 750px) 100vw, 750px" /></noscript></div></div></div></div></div></div></div><div class="fl-col-group fl-node-5cafe51078d7c fl-col-group-equal-height fl-col-group-align-top" data-node="5cafe51078d7c"><div class="fl-col fl-node-5cafe51078dba" data-node="5cafe51078dba"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-heading fl-node-5cafe51078e33" data-node="5cafe51078e33"><div class="fl-module-content fl-node-content"><h1 class="fl-heading"> <span class="fl-heading-text">Pakistan Navy’s fire power display – Stability through deterrence</span></h1></div></div><div class="fl-module fl-module-fl-post-info fl-node-5cafe51078ead" data-node="5cafe51078ead"><div class="fl-module-content fl-node-content"> <span class="fl-post-info-author"><a href="https://thefrontierpost.com/author/jalil/">The Frontier Post</a></span><span class="fl-post-info-sep"> / </span><span class="fl-post-info-date">November 7, 2020</span></div></div><div class="fl-module fl-module-fl-post-content fl-node-5cafe51078df7" data-node="5cafe51078df7"><div class="fl-module-content fl-node-content"><p>Ehsan Ahmed Khan</p><p>Allah orders in the Quran “And prepare for them whatever power and whatever garrisoned horses you can, to (spread) awe thereby into (the hearts) of the enemy of Allah and your enemy, and others, apart from them (i.e., besides them) that you do not know; Allah knows them.” (Surah Al Anfal Verse 60).</p><p>These verses are not just the metaphoric description of military preparations more than 1400 years ago, but delineate the principles of deterrence.With the increase in lethality of modern age weapons and global averseness towards fighting large scale conventional wars especially amongst rival with equitable war fighting and power projection potential, the space for war has shrunk. Conversely, todays war fighting is wrapped in many cloaks that are inclusive of kinetic as well as non-kinetic means, commonly referred to as hybrid warfare. The corner stone objective remains to avoid wars and that is achieved by maintaining effective deterrence in all dimensions i.e air, land and sea. Hence contemporary armed forces are structured and configured not only to fight and win wars but essentially to deter wars.</p><p>Historically geopolitics remained land centric and that’s where most wars had been fought for the control of territory. With transition of geo-strategy in favour of geo-economics, maritime security has gained increasing significance with a desire of maritime powers to uphold principal of Mare Liberum while concurrently safeguarding own interests.</p><p>As a fall out of end of British Colonial rule over Indian Subcontinent, the military hardware was distributed amongst Indian and Pakistan armed forces. It was an unjust distribution which grossly favoured India. The distribution was even starker in case of Pakistan Navy which had a very humble beginning in 1947. But over time Pakistan Navy has grown in size and capability transforming into a regional maritime force to reckon. Throughout its history Pakistan Navy, despite being enormously out gunned and outnumbered, had kept a numerically much superior enemy at bay. Destruction of radar station at Dwarka and bottling up of entire Indian Navy in port in 65, sinking of Khukri in 71 by submarine (an achievement only by PN and Royal Navy post WW-II), detection and confrontations with Indian submarines in 2016 and 19 (post Pulwama) is reflection of Pakistan Navy’s commitment to its task and above all its perpetual operational readiness.</p><p>On October, 28 Pakistan Navy carried out an impressive fire power demonstration in North Arabian Sea that included launch of a number of offensive weapons from different surface and air platforms. The successful destruction of targets at extended ranges speaks volumes of proficiency of Pakistan Navy’s personnel and reaffirms its strong combat capabilities to respond against any act of aggression by an adversary. While Pakistan Navy has gradually transited towards achieving self-reliance in anti-surface and land attack capabilities, successful engagement of targets by erstwhile anti-ship missiles also indicates the proficiency of PN personnel with reliable logistical and maintenance systems that ensures operational and war worthiness of systems that were procured decades earlier. On the contrary India has been struggling for reliability of its acquired as well as locally built missile systems, not to mention the recent dismal performance of much boasted Nirbhay cruise missile which failed again despite years of testing and trials.</p><p>Pakistan Navy fire power demonstration was very aptly timed just after the Indian Navy test fired its own set of missiles along its coast. These tests come at a time when India is bloating with its self-assumed status of “Net Security Provider” through new found honeymoon with the United States and being partner to QUAD or “Asian NATO” to challenge growing Chinese influence in the region. The message from Pakistan was firm and clear to digress India from its misconceived ideas of becoming regional hegemon, altering the regional security stability and intimidating Pakistan. Simply put the punch line is; any misadventure at sea would be dealt firmly and with parity in effects. Another aspect of this fire power display was the Chief of the Navy’s presence on the frontline amongst his troops shortly after assuming command of the Navy. This purely reflects the clarity in operational thought and seamless linkage from strategic to tactical level and unanimity of intent of the leader as well the lead.</p><p>Since Pakistan’s independence every successive Indian government, especially the incumbent fascist regime, has been literally bending over its back to undo Pakistan. It continues to amass billions of dollars’ worth military hardware but blatantly ignores the miserable plight of its own poverty struck population. Indian hegemonic desires coupled with hysteric paranoia over CPEC and more recent signing of BECA with US can disturb the regional security balance. Pakistan Navy’s recent live weapons firing is not only a positive step towards maintaining and promoting regional stability through deterrence but also an unwavering display of it intent against a belligerent hegemon.</p><div id='jp-relatedposts' class='jp-relatedposts' ></div></div></div><div class="fl-module fl-module-separator fl-node-5cafe51078f28" data-node="5cafe51078f28"><div class="fl-module-content fl-node-content"><div class="fl-separator"></div></div></div></div></div><div class="fl-col fl-node-5cafe8461eb60 fl-col-small fl-visible-desktop-medium" data-node="5cafe8461eb60"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-menu fl-node-5cafe871069c4" data-node="5cafe871069c4"><div class="fl-module-content fl-node-content"><div class="fl-menu fl-menu-responsive-toggle-mobile"> <button class="fl-menu-mobile-toggle hamburger" aria-label="Menu"><span class="svg-container"><svg version="1.1" class="hamburger-menu" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" viewBox="0 0 512 512"> <rect class="fl-hamburger-menu-top" width="512" height="102"/> <rect class="fl-hamburger-menu-middle" y="205" width="512" height="102"/> <rect class="fl-hamburger-menu-bottom" y="410" width="512" height="102"/> </svg> </span></button><div class="fl-clear"></div> <nav aria-label="Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-menu-1" class="menu fl-menu-vertical fl-toggle-none"><li id="menu-item-254676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home"><a href="https://thefrontierpost.com">Home</a></li><li id="menu-item-252278" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#top-stories">Top Stories</a></li><li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/global/">Global</a></li><li id="menu-item-62" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/business/">Business</a></li><li id="menu-item-259425" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/epaper-3/">E-Paper</a></li><li id="menu-item-41618" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#article">Articles</a></li><li id="menu-item-41617" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#editorial">Editorials</a></li><li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/pakistan/">Pakistan</a></li><li id="menu-item-63" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/entertainment/">Entertainment</a></li><li id="menu-item-61" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/afganistan/">Afghanistan</a></li><li id="menu-item-118020" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/arts-literature/">Arts &#038; Literature</a></li><li id="menu-item-252261" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#sports">Sports</a></li><li id="menu-item-252262" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#science-technology">Science &#038; Technology</a></li><li id="menu-item-252263" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#health">Health</a></li><li id="menu-item-252264" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#travel">Travel</a></li><li id="menu-item-252265" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#pictures-talks">Pictures Talk</a></li><li id="menu-item-252266" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#kids-corner">Kids Corner</a></li><li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-64" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/about-us/">About Us</a></li><li id="menu-item-65" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/contact-us/">Contact Us</a></li></ul></nav></div></div></div></div></div></div><div class="fl-col-group fl-node-5cafe635406a0 fl-col-group-equal-height fl-col-group-align-top" data-node="5cafe635406a0"><div class="fl-col fl-node-5cafe6354124b" data-node="5cafe6354124b"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-html fl-node-5cafe51078ffd" data-node="5cafe51078ffd"><div class="fl-module-content fl-node-content"><div class="fl-html"> <span style="font-style:italic;">Posted in <a href="https://thefrontierpost.com/category/article/" rel="tag" class="article">Article</a></span></div></div></div></div></div></div></div></div></div></div><div class="uabb-js-breakpoint" style="display: none;"></div></div><!-- .col-full --></div><!-- #content --> <footer id="colophon" class="site-footer" role="contentinfo"><div class="col-full"><div class="fl-builder-content fl-builder-content-119217 fl-builder-global-templates-locked" data-post-id="119217" data-type="footer" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div id="footer4body" class="fl-row fl-row-full-width fl-row-bg-color fl-node-5ca24118d4a17" data-node="5ca24118d4a17"><div class="fl-row-content-wrap"><div class="uabb-row-separator uabb-top-row-separator" ></div><div class="fl-row-content fl-row-fixed-width fl-node-content"><div class="fl-col-group fl-node-5ca24118d4a53 fl-col-group-equal-height fl-col-group-align-top" data-node="5ca24118d4a53"><div class="fl-col fl-node-5ca24118d4bf7 fl-col-small" data-node="5ca24118d4bf7"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-heading fl-node-5ca24118d4c35" data-node="5ca24118d4c35"><div class="fl-module-content fl-node-content"><h2 class="fl-heading"> <span class="fl-heading-text">Site Links</span></h2></div></div><div class="fl-module fl-module-menu fl-node-5ca24118d4c62 footer-menu" data-node="5ca24118d4c62"><div class="fl-module-content fl-node-content"><div class="fl-menu"><div class="fl-clear"></div> <nav aria-label="Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"><ul id="menu-menu-2" class="menu fl-menu-vertical fl-toggle-none"><li id="menu-item-254676" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home"><a href="https://thefrontierpost.com">Home</a></li><li id="menu-item-252278" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#top-stories">Top Stories</a></li><li id="menu-item-59" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/global/">Global</a></li><li id="menu-item-62" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/business/">Business</a></li><li id="menu-item-259425" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/epaper-3/">E-Paper</a></li><li id="menu-item-41618" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#article">Articles</a></li><li id="menu-item-41617" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#editorial">Editorials</a></li><li id="menu-item-60" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/pakistan/">Pakistan</a></li><li id="menu-item-63" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/entertainment/">Entertainment</a></li><li id="menu-item-61" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/afganistan/">Afghanistan</a></li><li id="menu-item-118020" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/arts-literature/">Arts &#038; Literature</a></li><li id="menu-item-252261" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#sports">Sports</a></li><li id="menu-item-252262" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#science-technology">Science &#038; Technology</a></li><li id="menu-item-252263" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#health">Health</a></li><li id="menu-item-252264" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#travel">Travel</a></li><li id="menu-item-252265" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#pictures-talks">Pictures Talk</a></li><li id="menu-item-252266" class="menu-item menu-item-type-custom menu-item-object-custom"><a href="/#kids-corner">Kids Corner</a></li><li id="menu-item-57" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/advertise-with-us/">Advertise with Us</a></li><li id="menu-item-64" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/about-us/">About Us</a></li><li id="menu-item-65" class="menu-item menu-item-type-post_type menu-item-object-page"><a href="https://thefrontierpost.com/contact-us/">Contact Us</a></li></ul></nav></div></div></div></div></div><div class="fl-col fl-node-5ca24118d4cc4 fl-col-small" data-node="5ca24118d4cc4"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-widget fl-node-5ca24118d4c87" data-node="5ca24118d4c87"><div class="fl-module-content fl-node-content"><div class="fl-widget"><div class="widget widget_recent_entries"><h2 class="widgettitle">Recent Posts</h2><ul><li> <a href="https://thefrontierpost.com/the-days-of-abramovich-being-ruthless-are-over-lampard-will/">“The days of Abramovich being ruthless are over” – Lampard will&#8230;</a></li><li> <a href="https://thefrontierpost.com/sbp-would-continue-to-facilitate-industry-businesses-dr-baqir/">SBP would continue to facilitate industry, businesses: Dr Baqir</a></li><li> <a href="https://thefrontierpost.com/kitchen-items-prices-ease-as-spi-falls-0-12-pc/">Kitchen items’ prices ease as SPI falls 0.12 pc</a></li><li> <a href="https://thefrontierpost.com/first-online-offline-industrial-exhibition-in-lahore-from-nov-13/">First ‘Online-Offline’ Industrial Exhibition in Lahore from Nov. 13</a></li><li> <a href="https://thefrontierpost.com/high-flying-us-tech-stocks-get-post-election-lift-near-new-highs/">High-flying US tech stocks get post-election lift, near new highs</a></li><li> <a href="https://thefrontierpost.com/e-commerce-boom-drives-courier-business/">E-commerce boom drives courier business</a></li><li> <a href="https://thefrontierpost.com/fire-safety-session-for-businesses-at-lcci/">Fire safety session for businesses at LCCI</a></li><li> <a href="https://thefrontierpost.com/johnny-depp-due-to-scandal-with-amber-heard-was-deprived-of-a-role-in-fantastic-beasts/">Johnny Depp due to scandal with Amber Heard was deprived of a role in &#8220;Fantastic Beasts&#8221;</a></li><li> <a href="https://thefrontierpost.com/sharia-law-the-personal-life-of-the-star-of-the-magnificent-century-burak-ozchivit/">Sharia law: the personal life of the star of the &#8220;Magnificent Century&#8221; Burak Ozchivit</a></li><li> <a href="https://thefrontierpost.com/pakistan-navys-fire-power-display-stability-through-deterrence/" aria-current="page">Pakistan Navy’s fire power display – Stability through deterrence</a></li></ul></div></div></div></div></div></div><div class="fl-col fl-node-5ca24118d4acb fl-col-small" data-node="5ca24118d4acb"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-heading fl-node-5ca2436f696d1" data-node="5ca2436f696d1"><div class="fl-module-content fl-node-content"><h2 class="fl-heading"> <span class="fl-heading-text">Subscribe!</span></h2></div></div><div class="fl-module fl-module-rich-text fl-node-5ca24118d4fd0" data-node="5ca24118d4fd0"><div class="fl-module-content fl-node-content"><div class="fl-rich-text"><p><span style="color:#ffffff ">Sign up for our newsletter!</span></p></div></div></div><div id="footer4subscribe" class="fl-module fl-module-subscribe-form fl-node-5ca24118d4e2d" data-node="5ca24118d4e2d"><div class="fl-module-content fl-node-content"><div class="fl-subscribe-form fl-subscribe-form-stacked fl-subscribe-form-name-show fl-form fl-clearfix" ><div class="fl-form-field"> <label for="fl-subscribe-form-name" class="hidden">Name</label> <input type="text" aria-describedby="name-error" name="fl-subscribe-form-name" placeholder="Name" id="fl-subscribe-form-name" /><div class="fl-form-error-message" id="name-error">Please enter your name.</div></div><div class="fl-form-field"> <label for="fl-subscribe-form-email" class="hidden">Email Address</label> <input type="email" aria-describedby="email-error" name="fl-subscribe-form-email" placeholder="Email Address" id="fl-subscribe-form-email" /><div class="fl-form-error-message" id="email-error">Please enter a valid email address.</div></div><div class="fl-form-button" data-wait-text="Please Wait..."><div class="fl-button-wrap fl-button-width-full fl-button-left"> <a href="#" target="_self" class="fl-button" role="button"> <span class="fl-button-text">Subscribe!</span> </a></div></div><div class="fl-form-success-message"><p>Thanks for subscribing! Please check your email for further instructions.</p></div><div class="fl-form-error-message">Something went wrong. Please check your entries and try again.</div></div></div></div><div class="fl-module fl-module-separator fl-node-5ca2415939282" data-node="5ca2415939282"><div class="fl-module-content fl-node-content"><div class="fl-separator"></div></div></div></div></div></div></div></div></div><div id="footer4copyright" class="fl-row fl-row-full-width fl-row-bg-color fl-node-5ca24118d4925" data-node="5ca24118d4925"><div class="fl-row-content-wrap"><div class="uabb-row-separator uabb-top-row-separator" ></div><div class="fl-row-content fl-row-fixed-width fl-node-content"><div class="fl-col-group fl-node-5ca24118d4963 fl-col-group-equal-height fl-col-group-align-center fl-col-group-custom-width" data-node="5ca24118d4963"><div class="fl-col fl-node-5ca24118d49a0 fl-col-small" data-node="5ca24118d49a0"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-rich-text fl-node-5ca24118d49dc" data-node="5ca24118d49dc"><div class="fl-module-content fl-node-content"><div class="fl-rich-text"><p>© 2018 The Frontier Post</p></div></div></div></div></div><div class="fl-col fl-node-5ca24118d4f58 fl-col-small" data-node="5ca24118d4f58"><div class="fl-col-content fl-node-content"><div class="fl-module fl-module-html fl-node-5ca24118d4f94" data-node="5ca24118d4f94"><div class="fl-module-content fl-node-content"><div class="fl-html"><div align="right"> <a rel="nofollow" href="https://www.godaddy.com/websites/web-design"
target="_blank"><img alt="GoDaddy Web Design"
src="//nebula.wsimg.com/aadc63d8e8dbd533470bdc4e350bc4af?AccessKeyId=B7351D786AE96FEF6EBB&disposition=0&alloworigin=1"></a></div></div></div></div></div></div></div></div></div></div></div><div class="uabb-js-breakpoint" style="display: none;"></div></div><!-- .col-full --> </footer><!-- #colophon --></div><!-- #page --> <script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.0.2/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script><script type='text/javascript' id='fvm-footer-1-js-extra'>/*  */
var GEM = {"thankyou":"Thank you for signing up!","thankyou_suppressed":"Thank you for signing up! Please check your email to confirm your subscription.","oops":"Oops! There was a problem. Please try again.","email":"Please enter a valid email address.","required":"%s is a required field."};
/*  */</script> <script type='text/javascript' src='https://thefrontierpost.com/wp-content/uploads/cache/fvm/1603366958/out/footer-2841e465efad9e49364ca0172609ea1a16f945a7.min.js' id='fvm-footer-1-js'></script><script type='text/javascript' src='https://c0.wp.com/c/5.5.3/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script><script type='text/javascript' src='https://stats.wp.com/e-202045.js' async='async' defer='defer'></script> <script type='text/javascript'>_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.0.2',blog:'137582343',post:'269379',tz:'0',srv:'thefrontierpost.com'} ]);
	_stq.push([ 'clickTrackerInit', '137582343', '269379' ]);</script> </body></html>